myDC.ru

Здравствуйте, гость ( Вход | Регистрация )

 
 
Ответить в данную темуНачать новую тему

> Проблема при установке плагина lua для верлихаба

Теги
Нет тегов для показа
sabriel
сообщение 20.9.2011, 7:41
Сообщение #1


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Здравствуйте, помогите решить проблему
есть верлихаб 0.9.8e-r2
есть lua 5.1.4 и luasocket 2.0.2
пытаюсь поставить луа плагин 1.8.1
./configure проходит успешно
но на make
выдает вот какие ошибки
Код
cluainterpreter.cpp: In destructor ‘nScripts::cLuaInterpreter::~cLuaInterpreter()’:
cluainterpreter.cpp:48:30: warning: deprecated conversion from string constant to ‘char*’
cluainterpreter.cpp: In member function ‘bool nScripts::cLuaInterpreter::Init()’:
cluainterpreter.cpp:66:20: error: ‘luaopen_loadlib’ was not declared in this scope
cluainterpreter.cpp:120:57: error: ‘lua_dofile’ was not declared in this scope
cluainterpreter.cpp: In member function ‘void nScripts::cLuaInterpreter::Load()’:
cluainterpreter.cpp:137:27: warning: deprecated conversion from string constant to ‘char*’
make[2]: *** [cluainterpreter.lo] Error 1
make[2]: Leaving directory `/home/sabriel/lua-1.8.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sabriel/lua-1.8.1'
make: *** [all] Error 2

помогите разобраться
Go to the top of the page
+Quote Post
Setuper
сообщение 20.9.2011, 8:43
Сообщение #2


RusHub team lead
**************

Группа: Модераторы
Сообщений: 4 030
Регистрация: 20.6.2008
Из: г. Королёв (Моск. обл.)
Пользователь №: 46
Спасибо сказали: 1707 раз




Поставь lua версии пониже.
Go to the top of the page
+Quote Post
sabriel
сообщение 20.9.2011, 10:25
Сообщение #3


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Цитата(Setuper @ 20.9.2011, 14:43) *
Поставь lua версии пониже.

всмысле плагин?
луа пробовал 5.0.2 такая же картина.
Go to the top of the page
+Quote Post
mariner
сообщение 20.9.2011, 11:28
Сообщение #4


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




тогда подозреваю, что у вас нет необходимых заголовочных файлов в системе.
Go to the top of the page
+Quote Post
sabriel
сообщение 20.9.2011, 11:48
Сообщение #5


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Ну так он же не ругается на хедеры?
должны же быть какие то намеки чего ему не хватает. а тут просто на функции ругается получается...
может подскажете про какие заголовочные файлы вы думаете?

Кстати на debian e завелось без проблем. но моя проблема в убунте. и ее хотелось бы решить)
Go to the top of the page
+Quote Post
Setuper
сообщение 20.9.2011, 12:14
Сообщение #6


RusHub team lead
**************

Группа: Модераторы
Сообщений: 4 030
Регистрация: 20.6.2008
Из: г. Королёв (Моск. обл.)
Пользователь №: 46
Спасибо сказали: 1707 раз




С lua 5.0.2 не может быть такой же картины. То есть точно таких же ошибок не должно быть.
Если возникают точно такие же ошибки, то значит ты неправильно ставишь lua.
Go to the top of the page
+Quote Post
mariner
сообщение 20.9.2011, 13:22
Сообщение #7


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




Цитата
Кстати на debian e завелось без проблем.

Список установленных пакетов в студию. dpkg -l | grep liblua5.1
Go to the top of the page
+Quote Post
vex112
сообщение 20.9.2011, 18:47
Сообщение #8


Участник
**

Группа: Пользователи
Сообщений: 32
Регистрация: 23.7.2009
Из: спб
Пользователь №: 3 949
Спасибо сказали: 1 раз




по этой инструкции на ubuntu 10.10 собирается влет и без траблов
Прикрепленные файлы
Прикрепленный файл  instr.txt ( 1.24 килобайт ) Кол-во скачиваний: 46
 
Go to the top of the page
+Quote Post
sabriel
сообщение 21.9.2011, 7:09
Сообщение #9


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Цитата(mariner @ 20.9.2011, 19:22) *
Список установленных пакетов в студию. dpkg -l | grep liblua5.1

Код
sabriel@sab:~$ dpkg -l | grep liblua5.1
ii  liblua5.1-0                                      5.1.4-5


Цитата(Setuper @ 20.9.2011, 18:14) *
С lua 5.0.2 не может быть такой же картины. То есть точно таких же ошибок не должно быть.
Если возникают точно такие же ошибки, то значит ты неправильно ставишь lua.

Код
cconsole.cpp:86:12: error: ‘LUA_RELEASE’ was not declared in this scope
make[2]: *** [cconsole.lo] Error 1
make[2]: Leaving directory `/home/sabriel/lua-1.8.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sabriel/lua-1.8.1'
make: *** [all] Error 2


Код
root@sab:/home/sabriel/lua-1.8.1# lua
Lua 5.0.2  Copyright (C) 1994-2004 Tecgraf, PUC-Rio


видимо может

Цитата(vex112 @ 21.9.2011, 0:47) *
по этой инструкции на ubuntu 10.10 собирается влет и без траблов

что косается инструкции пишет вот что
Код
Заметьте, вместо libmysqlclient15-dev выбирается libmysqlclient-dev
Пакет g++-4.3 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета g++-4.3 не найден кандидат на установку


стоит сейчас
Код
root@sab:/home/sabriel/lua-1.8.1# g++ --version
g++ (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.



Цитата(sabriel @ 21.9.2011, 12:46) *
Код
sabriel@sab:~$ dpkg -l | grep liblua5.1
ii  liblua5.1-0                                      5.1.4-5



Код
cconsole.cpp:86:12: error: ‘LUA_RELEASE’ was not declared in this scope
make[2]: *** [cconsole.lo] Error 1
make[2]: Leaving directory `/home/sabriel/lua-1.8.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sabriel/lua-1.8.1'
make: *** [all] Error 2


Код
root@sab:/home/sabriel/lua-1.8.1# lua
Lua 5.0.2  Copyright (C) 1994-2004 Tecgraf, PUC-Rio


видимо может


что косается инструкции пишет вот что
Код
Заметьте, вместо libmysqlclient15-dev выбирается libmysqlclient-dev
Пакет g++-4.3 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета g++-4.3 не найден кандидат на установку


стоит сейчас
Код
root@sab:/home/sabriel/lua-1.8.1# g++ --version
g++ (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

далее по интструкции делаю
Код
sudo ./configure --with-luasocket


он мне пишет
Код
checking for luaopen_socket_core in -lluasocket... no
configure: error: Please download and install LuaSocket from http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/.

Хотя

Код
lua
Lua 5.1.4  Copyright (C) 1994-2008 Lua.org, PUC-Rio
> socket = require("socket")
> print(socket._VERSION)
LuaSocket 2.0.2
Go to the top of the page
+Quote Post
mariner
сообщение 21.9.2011, 8:51
Сообщение #10


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




Код
sabriel@sab:~$ dpkg -l | grep liblua5.1
ii  liblua5.1-0                                      5.1.4-5

И это все луа-пакеты? Так не пойдет. Нужен еще как мимнмум liblua5.1-dev
Go to the top of the page
+Quote Post
sabriel
сообщение 21.9.2011, 9:29
Сообщение #11


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Цитата(mariner @ 21.9.2011, 14:51) *
Код
sabriel@sab:~$ dpkg -l | grep liblua5.1
ii  liblua5.1-0                                      5.1.4-5

И это все луа-пакеты? Так не пойдет. Нужен еще как мимнмум liblua5.1-dev

хм и правда странно маловато. пробовал разные варианты. из присланной инструкии. теперь вот так
Код
oot@sab:/home/sabriel/lua-1.8.1# dpkg -l | grep liblua5.1
ii  liblua5.1-0                                      5.1.4-5                                    Simple, extensible, embeddable programming language
ii  liblua5.1-0-dev                                  5.1.4-5                                    Simple, extensible, embeddable programming language
ii  liblua5.1-socket-dev                             2.0.2-4                                    TCP/UDP socket library for Lua 5.1
ii  liblua5.1-socket2                                2.0.2-4                                    TCP/UDP socket library for Lua 5.1


но ошибка все таже

сделал apt-get install liblua5.1 стало дико много пакетов, но ошибка не исчезла. может дело в компиляторе?
Go to the top of the page
+Quote Post
mariner
сообщение 21.9.2011, 9:59
Сообщение #12


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




вот только что попробовал в контейнере с 10.04 (ну он был под рукой - все собралось). Чистого контейнера с 6ым дебианом нет, но в принципе можно сделать и попробовать. Только думаю у меня соберется.
Go to the top of the page
+Quote Post
sabriel
сообщение 21.9.2011, 10:17
Сообщение #13


Абсолютный новичок


Группа: Пользователи
Сообщений: 8
Регистрация: 16.9.2011
Пользователь №: 9 718
Спасибо сказали: 1 раз




Цитата(mariner @ 21.9.2011, 15:59) *
вот только что попробовал в контейнере с 10.04 (ну он был под рукой - все собралось). Чистого контейнера с 6ым дебианом нет, но в принципе можно сделать и попробовать. Только думаю у меня соберется.

значит проблема именно в этой системе(в моей) чем она может быть засорена что такое? может есть какие нибудь предположения? на дебиане у меня тоже все собралось (повторюсь)
)
Go to the top of the page
+Quote Post

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

Collapse

> Похожие темы

  Тема Ответов Автор Просмотров Последнее сообщение
No New Posts Topic has attachmentsПроблема со скриптом Истории чата
5 SonicX 3 735 27.6.2014, 19:04 Посл. сообщение: sergius_s
No new внезапная непонятная проблема с хабом
17 aleksei1122 7 925 3.3.2013, 16:41 Посл. сообщение: Delia
No New Posts Проблема со скриптами на версии 0.4.2.0
5 Fe(one)X 3 971 16.2.2012, 21:28 Посл. сообщение: Fe(one)X
No new Topic has attachmentsПроблема с хабом после установки роутера
22 Jet1k 18 165 3.1.2012, 11:05 Посл. сообщение: Strannik
No New Posts Здравствуйте всем . У меня проблема со скриптам StatPX
Здравствуйте всем . У меня проблема со скриптам StatPX
4 warhammer 5 201 14.4.2011, 14:48 Посл. сообщение: warhammer
No New Posts Проблема с Remote_Admin
Не работает:(
1 el_toro 3 206 13.3.2011, 3:26 Посл. сообщение: Alexey
No New Posts XML. Проблема с плеером
размер шрифта
1 Rannau 3 368 28.2.2011, 9:53 Посл. сообщение: Setuper
No new Topic has attachmentsПроблема на PtоkaX 0.4.1.2 в скрипте
Проблема на PtоkaX 0.4.1.2 в скрипте
23 sania 12 555 23.2.2011, 15:37 Посл. сообщение: Saymon21
No New Posts Небольшая проблема Нужна ваша помощь !
Буду очень благодарен !!!
11 @_JuNiOr_@ 7 349 5.2.2011, 12:38 Посл. сообщение: Maximum
No New Posts От: Небольшая проблема Нужна ваша помощь !
От темы с ID: 4634
1 ScOol 2 665 3.2.2011, 17:48 Посл. сообщение: Maximum
No New Posts PtokaX 0.4.1.2 Win32 service/console Проблема с МОТД
Проблема с МОТД
3 @_JuNiOr_@ 5 387 13.12.2010, 23:42 Посл. сообщение: Ameet
No New Posts Проблема с подключением
на мой хаб не могут зайти
7 @denis@ 4 786 9.12.2010, 10:34 Посл. сообщение: Strannik
No New Posts Проблема ...
5 skonda 3 166 3.12.2010, 22:33 Посл. сообщение: skonda
No New Posts Проблема с МОТД
Кто поможет с меня +
11 Streter 7 899 6.11.2010, 20:56 Посл. сообщение: Wanderer
No New Posts проблема роутером
1 Talib 2 764 1.9.2010, 15:22 Посл. сообщение: mariner

 



RSS Сейчас: 25.9.2018, 22:57