myDC.ru

Здравствуйте, гость ( Вход | Регистрация )

 
 
Ответить в данную темуНачать новую тему

> как правильно подключить библиотеку luasocket?

Теги
Нет тегов для показа
MEXAHuK
сообщение 27.9.2009, 21:01
Сообщение #1


Освоившийся участник
*****

Группа: Пользователи
Сообщений: 314
Регистрация: 13.10.2008
Пользователь №: 791
Спасибо сказали: 9 раз




поставил на фряху 7.2 птоку. по мануалу
скомпилилось нормально
потом установил библиотеку луасокет (из портов)
установил обе
Код
Mexahuk# cd /usr/ports/net/luasocket
Mexahuk# make install clean    
Mexahuk# cd /usr/ports/net/lua50-luasocket
Mexahuk# make install clean

скомпилилось нормально

запустил скрипт Экзекутора и он мне начал писать
p, li { white-space: pre-wrap; } [/font]

[font="Verdana"]
Код
*** Sun Sep 27 23:49:59 2009 В скрипте произошла ошибка: error loading module 'socket.core' from file '/usr/local/lib/lua/5.1/socket/core.so':    /usr/local/lib/lua/5.1/socket/core.so: Undefined symbol "lua_insert"

раз в секунду в главный чат
поясните что нетак и как исправить.
Go to the top of the page
+Quote Post
Jaska
сообщение 27.9.2009, 21:09
Сообщение #2


Освоившийся участник
*****

Группа: Администраторы
Сообщений: 344
Регистрация: 2.6.2008
Из: RB,Ufa
Пользователь №: 8
Спасибо сказали: 106 раз




Точно та версия либы?
Go to the top of the page
+Quote Post
MEXAHuK
сообщение 28.9.2009, 4:37
Сообщение #3


Освоившийся участник
*****

Группа: Пользователи
Сообщений: 314
Регистрация: 13.10.2008
Пользователь №: 791
Спасибо сказали: 9 раз




как узнать и какая нужна?
Go to the top of the page
+Quote Post
mariner
сообщение 28.9.2009, 6:35
Сообщение #4


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 875
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




5.1 на линуксах нужна, с 5.0 не работает все, так, как надо.
Go to the top of the page
+Quote Post
MEXAHuK
сообщение 28.9.2009, 13:47
Сообщение #5


Освоившийся участник
*****

Группа: Пользователи
Сообщений: 314
Регистрация: 13.10.2008
Пользователь №: 791
Спасибо сказали: 9 раз




это ты для линукса написал. это справедливо для фряхи?


чтобы не создававть тему спрошу тут же: ты, Маринер, на каком дистре линукса собрал хаб? можешь написать как ты собирал?
потому как у меня:
применил патч. потом
Код
[root@localhost ptoka]# gmake
g++ -g -Wall -Itinyxml/src -I/usr/include -I/usr/local/include -I/usr/pkg/include -I/usr/local/include/lua51/ -c /home/Arcanum/ptoka/src/ClientTagManager.cpp -o /home/Mexahuk/ptoka/obj/ClientTagManager.o
gmake: g++: Команда не найдена
gmake: *** [/home/Mexahuk/ptoka/obj/ClientTagManager.o] Ошибка 127
Go to the top of the page
+Quote Post
Alexey
сообщение 28.9.2009, 14:40
Сообщение #6


7 квадратиков
*******

Группа: Модераторы
Сообщений: 793
Регистрация: 21.1.2009
Пользователь №: 1 895
Спасибо сказали: 301 раз




А у тебя там компилятор не установлен, походу.
Go to the top of the page
+Quote Post
mariner
сообщение 28.9.2009, 15:42
Сообщение #7


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 875
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




убунта, дебиан, центос, гента
Для убунты и дебиана я инсталлер даже собрал. Типо ставишь зависимости командой, а потом хаб. тема с инсталлером зовется "deb пакеты для дебиан/убунту"
Go to the top of the page
+Quote Post
MEXAHuK
сообщение 28.9.2009, 16:45
Сообщение #8


Освоившийся участник
*****

Группа: Пользователи
Сообщений: 314
Регистрация: 13.10.2008
Пользователь №: 791
Спасибо сказали: 9 раз




забыл сказать что я Фёдорофил 11...

Цитата(mariner @ 28.9.2009, 9:35) *
5.1 на линуксах нужна, с 5.0 не работает все, так, как надо.


это вы про что? про сокет или про луа?

и откуда качать либы чтобы их самому скомпилить и установить?
Go to the top of the page
+Quote Post
mariner
сообщение 28.9.2009, 18:50
Сообщение #9


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 875
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




Если ты федорофил, ты ты как минимум чокнутый. Использовать под сервер нестабильный дистр, это, однако, сильно. В дебиане и убунте оно есть в стандартных репозиториях.
Go to the top of the page
+Quote Post
MEXAHuK
сообщение 28.9.2009, 20:41
Сообщение #10


Освоившийся участник
*****

Группа: Пользователи
Сообщений: 314
Регистрация: 13.10.2008
Пользователь №: 791
Спасибо сказали: 9 раз




хех... кто сказал что я буду ставить птоку на федору
моя задача поставить на фряху.

мне тут очень хороший человек посоветовал подумать вот на этим и этим
пойду курить кальян.
Go to the top of the page
+Quote Post
Ksan
сообщение 28.9.2009, 21:19
Сообщение #11


Белый Волк
*********

Группа: Пользователи
Сообщений: 1 723
Регистрация: 11.9.2008
Из: г.Томск
Пользователь №: 516
Спасибо сказали: 657 раз




Кстати, владелец сервера, где стоит хаб, приделал LFS к своей Слакваре 11, я попытался запустить скрипт, использующий LFS, не получилось, выдало в лог такую же практически ошибку, которая показана выше:
Код
29.09.2009 00:51:23 - error loading module 'lfs' from file '/usr/local/lib/lua/5.1/lfs.so':
    /usr/local/lib/lua/5.1/lfs.so: undefined symbol: lua_touserdata
Go to the top of the page
+Quote Post
Sergey613
сообщение 12.10.2009, 19:57
Сообщение #12


Активный участник
***

Группа: Пользователи
Сообщений: 71
Регистрация: 8.4.2009
Пользователь №: 2 982
Спасибо сказали: 1 раз




Уважаемые!
Помогите установить luasocket на FreeBSD для PtokaX 4.1.1 под lua 5.1.4.
Приветствуется подробный мануальчик big_smile.gif
Go to the top of the page
+Quote Post
Wildcdu
сообщение 15.10.2009, 18:50
Сообщение #13


Начинающий
*

Группа: Пользователи
Сообщений: 20
Регистрация: 12.10.2009
Пользователь №: 4 708
Спасибо сказали: 2 раза




Цитата(Sergey613 @ 13.10.2009, 1:57) *
Уважаемые!
Помогите установить luasocket на FreeBSD для PtokaX 4.1.1 под lua 5.1.4.
Приветствуется подробный мануальчик big_smile.gif


присоеденяюсь!!!!!

и еще LFS у меня таже беда как пример:

16.10.2009 04:42:09 - error loading module 'lfs' from file '/usr/local/lib/lua/5.1/lfs.so':
/usr/local/lib/lua/5.1/lfs.so: Undefined symbol "luaL_checklstring"
Go to the top of the page
+Quote Post
Wildcdu
сообщение 17.10.2009, 21:43
Сообщение #14


Начинающий
*

Группа: Пользователи
Сообщений: 20
Регистрация: 12.10.2009
Пользователь №: 4 708
Спасибо сказали: 2 раза




Цитата(MEXAHuK @ 28.9.2009, 3:01) *
поставил на фряху 7.2 птоку. по мануалу
скомпилилось нормально
потом установил библиотеку луасокет (из портов)
установил обе
Код
Mexahuk# cd /usr/ports/net/luasocket
Mexahuk# make install clean    
Mexahuk# cd /usr/ports/net/lua50-luasocket
Mexahuk# make install clean

скомпилилось нормально

запустил скрипт Экзекутора и он мне начал писать
p, li { white-space: pre-wrap; } [/font]

[font="Verdana"]
Код
*** Sun Sep 27 23:49:59 2009 В скрипте произошла ошибка: error loading module 'socket.core' from file '/usr/local/lib/lua/5.1/socket/core.so':    /usr/local/lib/lua/5.1/socket/core.so: Undefined symbol "lua_insert"

раз в секунду в главный чат
поясните что нетак и как исправить.


хотелось бы узнать решился вопрос или нет??? аналог проблема можно сказать один в один!!! помогите кто нибудь!!!
Go to the top of the page
+Quote Post
Sergey613
сообщение 18.2.2010, 22:31
Сообщение #15


Активный участник
***

Группа: Пользователи
Сообщений: 71
Регистрация: 8.4.2009
Пользователь №: 2 982
Спасибо сказали: 1 раз




Что, так и никто не знает, как сокеты установить правильно?
Go to the top of the page
+Quote Post

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

Collapse

> Похожие темы

  Тема Ответов Автор Просмотров Последнее сообщение
No new Topic has attachmentsLuasocket
win32 | Работа с сокетами
42 Nickolya 65 929 17.6.2015, 1:59 Посл. сообщение: Yamakasi
No new Topic has attachmentsОт: Luasocket
От темы с ID: 43
19 Tarantul13 16 301 12.10.2013, 0:01 Посл. сообщение: Alexey
No New Posts ВАЖНО: Сборка хаба PtokaX 0.4.1.2 с поддержкой Lua и luasocket в ОС Solaris 10 x86
Краткое описание сборки PtokaX 0.4.1.2 в ОС Solaris
7 Gatsu 13 983 2.2.2012, 19:49 Посл. сообщение: Gatsu
No New Posts Topic has attachmentsluasocket
RusHub | Библиотека сокетов
5 Setuper 15 227 1.8.2011, 22:42 Посл. сообщение: Saymon21
No New Posts От: luasocket
От темы с ID: 2951
4 Saymon21 6 410 3.3.2011, 0:31 Посл. сообщение: Midgard
No New Posts ВАЖНО: Как правильно задавать вопросы
полезный материал, для чайников обязателен к прочтению!
2 Nickolya 7 837 28.11.2010, 0:16 Посл. сообщение: Ksan

 



RSS Сейчас: 24.2.2024, 15:37