myDC.ru

Здравствуйте, гость ( Вход | Регистрация )

 
 
Ответить в данную темуНачать новую тему

> LFS, win32 - API 2 | Библиотека файловой системы

Setuper
сообщение 23.5.2009, 1:59
Сообщение #1


RusHub team lead
**************

Группа: Модераторы
Сообщений: 4 030
Регистрация: 20.6.2008
Из: г. Королёв (Моск. обл.)
Пользователь №: 46
Спасибо сказали: 1694 раза




Библиотека работы с файловой системой.

Название: LuaFileSystem (LFS)
Версия API: 2
Версия библиотеки: 1.4.2
Версия LUA: 5.1
Авторы: Roberto Ierusalimschy, André Carregal, Tomás Guisasola

Подключение библиотеки:
Код
require"pxlfs"
Все функции библиотеки после подключения будут находиться в глобальной таблице lfs.

Прикрепленный файл  PXLFS.rar ( 53.93 килобайт ) Кол-во скачиваний: 739


Спасибо сказали:
Go to the top of the page
+Quote Post
vicious
сообщение 23.5.2009, 18:19
Сообщение #2


Продвинутый участник
****

Группа: Пользователи
Сообщений: 173
Регистрация: 26.1.2009
Из: Saratov
Пользователь №: 1 965
Спасибо сказали: 6 раз




А вот Мануал в помощь : http://www.keplerproject.org/luafilesystem...ml#introduction


Спасибо сказали:
Go to the top of the page
+Quote Post
fixx
сообщение 30.5.2009, 22:54
Сообщение #3


МЕДВЕД =)
****

Группа: Пользователи
Сообщений: 187
Регистрация: 6.8.2008
Пользователь №: 332
Спасибо сказали: 3 раза




Setuper
Вот меня задрал вопрос..
Ну допускаю, что мускул разработчикам ненужен, допускаю, что еще хз что не нужно, но файловая система (имхо) для ТАКОГО приложения, ну никак лишней небудет.
Понимаю, что к разработчикам Птоки Вы никакого отношения не имеете, но хочу всеж спросить, как программиста:
Почему они (разработчики) невписали эту либу в дистр?
Ну а, развивая вопрос, почему бы им не включить в дистр и либу на мускул?
Спрашиваю чисто из любопытства. Хочу понять ход их мыслей..
===============
зы, "закуячить либу в дистр" - я подразумеваю "сделать дистр, который будет "дружить" сам собой ... ну, допустим с мускулом, не прибегая к помощи сторонних библиотек.
Чисто мнение Ваше интересует.. big_smile.gif
Go to the top of the page
+Quote Post
mariner
сообщение 30.5.2009, 22:59
Сообщение #4


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 219 раз




Просто PPK живет в параллельной реальности, где нет mysql, а файловые системы - страшный миф big_smile.gif
Go to the top of the page
+Quote Post
Setuper
сообщение 30.5.2009, 23:15
Сообщение #5


RusHub team lead
**************

Группа: Модераторы
Сообщений: 4 030
Регистрация: 20.6.2008
Из: г. Королёв (Моск. обл.)
Пользователь №: 46
Спасибо сказали: 1694 раза




Просто всё дело в оптимизации. Зачем в экзешник включать этот мусор, если не используешь его? Кто будет использовать, тот подключит!
Go to the top of the page
+Quote Post
DriverZX-10
сообщение 30.8.2009, 3:53
Сообщение #6


Участник
**

Группа: Пользователи
Сообщений: 41
Регистрация: 25.8.2009
Из: Московская область,Электроугли
Пользователь №: 4 252
Спасибо сказали: 1 раз




Сори,а поподробнее для чайников мона как подключать библиотеку?А то больно нужная вещичка для удалённого администрирования хаба,через р-админа уже заматался его настраивать...
Куда папку с библиотекой LuaFileSystem (LFS) копировать и куда этот
Код
require"pxlfs"

кодик впихивать??
Go to the top of the page
+Quote Post
Jaska
сообщение 30.8.2009, 8:45
Сообщение #7


Освоившийся участник
*****

Группа: Администраторы
Сообщений: 344
Регистрация: 2.6.2008
Из: RB,Ufa
Пользователь №: 8
Спасибо сказали: 104 раза




Библиотеку скопируй в папку с PtokaX.exe, require"pxlfs" вставляй в код скрипта, где тебе необходимо подключить библиотеку.
Go to the top of the page
+Quote Post
DriverZX-10
сообщение 30.8.2009, 23:53
Сообщение #8


Участник
**

Группа: Пользователи
Сообщений: 41
Регистрация: 25.8.2009
Из: Московская область,Электроугли
Пользователь №: 4 252
Спасибо сказали: 1 раз




Цитата(Jaska @ 30.8.2009, 5:45) *
require"pxlfs" вставляй в код скрипта, где тебе необходимо подключить библиотеку.

Извините за мб тупой вопрос(не скриптер я)-в какое место в скрипте вставлять и в какой скрипт - во все или только в какой-то определённый, которым необходимо управлять удалённо в случае с PXControl?
Go to the top of the page
+Quote Post
Setuper
сообщение 30.8.2009, 23:57
Сообщение #9


RusHub team lead
**************

Группа: Модераторы
Сообщений: 4 030
Регистрация: 20.6.2008
Из: г. Королёв (Моск. обл.)
Пользователь №: 46
Спасибо сказали: 1694 раза




Данную библиотеку нужно скопировать либо в папку с ptokax.exe, либо в папку libs
А вставлять нужно в начале скрипта, который нуждается в этой библиотеке.

По поводу PXControl следует задавать вопросы в соответствующей теме!


Спасибо сказали:
Go to the top of the page
+Quote Post
Дьяволёнок
сообщение 2.6.2014, 2:53
Сообщение #10


Абсолютный новичок


Группа: Пользователи
Сообщений: 6
Регистрация: 7.1.2012
Пользователь №: 10 148
Спасибо сказали: 0 раз




вот какраз таки и непахает с тем скрипто ругается про точку входа ППЦ
Go to the top of the page
+Quote Post
Alexey
сообщение 2.6.2014, 14:50
Сообщение #11


7 квадратиков
*******

Группа: Модераторы
Сообщений: 791
Регистрация: 21.1.2009
Пользователь №: 1 895
Спасибо сказали: 286 раз




Выложенные ранее в этой теме библиотеки не будут работать на PtokaX 0.4.2.0 и более новых.

Для работы с LuaFileSystem на PtokaX 0.5.0.2 следует использовать эти:
Прикрепленный файл  LuaFileSystem_1.6.2.7z ( 258.09 килобайт ) Кол-во скачиваний: 38
Прикрепленный файл  LuaFileSystem_1.6.2_x64.7z ( 254.37 килобайт ) Кол-во скачиваний: 22


Библиотека LuaFileSystem для PtokaX 0.5.0.3:
Прикрепленный файл  LuaFileSystem_1.6.3.7z ( 264.61 килобайт ) Кол-во скачиваний: 13
Прикрепленный файл  LuaFileSystem_1.6.3_x64.7z ( 259.5 килобайт ) Кол-во скачиваний: 20


В старых скриптах может потребоваться изменить способ подключения библиотеки с require("pxlfs") на require("lfs")


Спасибо сказали:
Go to the top of the page
+Quote Post
MIKHAIL
сообщение 25.3.2017, 11:40
Сообщение #12


KEEP CLEAR AT ALL TIMES
****

Группа: Пользователи
Сообщений: 135
Регистрация: 4.9.2011
Из: Беларусь, Минск
Пользователь №: 9 667
Спасибо сказали: 1 раз




Версия библиотеки PXLFS из шапки не 1.4.2, а ["_VERSION"] = "LuaFileSystem 1.2.1".
Go to the top of the page
+Quote Post

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Сейчас: 20.9.2017, 3:02