myDC.ru

Здравствуйте, гость ( Вход | Регистрация )

 

> Модули Lua В Linux, приветы те многие

Теги
Нет тегов для показа
mariner
сообщение 9.4.2009, 12:49
Сообщение #41


Местная ТехПоддержка
**********

Группа: Администраторы
Сообщений: 1 874
Регистрация: 18.7.2008
Из: Моск. Обл, г. королев, район Болшево
Пользователь №: 221
Спасибо сказали: 220 раз




В общем, меня откровенно измучила народная масса, взрывающая мою аську в просьбе помощи по скриптам под Linux (дада, ребят, не обессутьте, но вас много extreme_sexy_girl.gif )
Начнем с модулей Lua
Для вызова модулей:
libmd5 - require("md5")
libfilesystem - require("lfs")

Про пути до файлов скриптов читаем тут!
Про установку и тесты библиотек читаем тут.


Собственно еще тут будут выкладываться переделанные скрипты:
1. Webconfig & WebReg by Nicolya (Unix repack)
Для работы скрипта нужны пакеты:
liblua5.1-filesystem и liblua5.1-socket (искать в репозиториях)
Прикрепленный файл  www_config.tar.gz ( 17.49 килобайт ) Кол-во скачиваний: 84


2. Монитор игровых серверов на основе протокола HL(1/2)
Он же SourceMon by alex82
Для работы надо: liblua5.1-socket - сматрим репозитории
Прикрепленный файл  sourceMon_unix_repack_.zip ( 6.74 килобайт ) Кол-во скачиваний: 38


Спасибо сказали:
Go to the top of the page
+Quote Post
3 страниц V  < 1 2 3  
Начать новую тему
Ответов
Iskandark
сообщение 9.1.2014, 19:52
Сообщение #42


Активный участник
***

Группа: Пользователи
Сообщений: 61
Регистрация: 24.10.2008
Из: Moscow
Пользователь №: 875
Спасибо сказали: 0 раз




Собрал Ptokax 5.0.1 c lua5.2, теперь в строке скрипта с require "socket" выдает ошибку:

Thu 09 Jan 2014 08:46:33 PM MSK - /etc/ptokaxv/scripts/Quiz.lua:12: module 'socket' not found:
no field package.preload['socket']
no file '/usr/local/share/lua/5.2/socket.lua'
no file '/usr/local/share/lua/5.2/socket/init.lua'
no file '/usr/local/lib/lua/5.2/socket.lua'
no file '/usr/local/lib/lua/5.2/socket/init.lua'
no file './socket.lua'

Установлена библиотека liblua5.1-socket2. Для lua5.2 такой библиотеки в репозитарии debian нет.

Можно ли использовать каким либо образом библиотеку liblua5.1-socket2, если PtokaX собрана с lua5.2?

Или возможен как-либо другой вариант?
Go to the top of the page
+Quote Post
Alexey
сообщение 9.1.2014, 21:47
Сообщение #43


7 квадратиков
*******

Группа: Модераторы
Сообщений: 792
Регистрация: 21.1.2009
Пользователь №: 1 895
Спасибо сказали: 300 раз




Цитата(Iskandark @ 9.1.2014, 19:52) *
Можно ли использовать каким либо образом библиотеку liblua5.1-socket2, если PtokaX собрана с lua5.2?

Нет, нельзя.

Цитата(Iskandark @ 9.1.2014, 19:52) *
Или возможен как-либо другой вариант?

И не один:
  1. Собрать библиотеку с Lua 5.2 самостоятельно.
  2. Собрать птоку с Lua 5.1.
  3. Поменять OS на ту, где нужные зависимости есть в репозитариях.


Спасибо сказали:
Go to the top of the page
+Quote Post
Iskandark
сообщение 9.1.2014, 23:33
Сообщение #44


Активный участник
***

Группа: Пользователи
Сообщений: 61
Регистрация: 24.10.2008
Из: Moscow
Пользователь №: 875
Спасибо сказали: 0 раз




Цитата(Alexey @ 9.1.2014, 22:47) *
Нет, нельзя.


И не один:
  1. Собрать библиотеку с Lua 5.2 самостоятельно.
  2. Собрать птоку с Lua 5.1.
  3. Поменять OS на ту, где нужные зависимости есть в репозитариях.


Хотел собрать PtokaX 0.5.0.1 с Lua 5.1, но не собирается, выдает ошибку:
Раскрывающийся текст
/home/alex/source/ptokax# make
g++ /home/alex/source/ptokax/obj/colUsers.o /home/alex/source/ptokax/obj/DcCommands.o /home/alex/source/ptokax/obj/DeFlood.o /home/alex/source/ptokax/obj/eventqueue.o /home/alex/source/ptokax/obj/GlobalDataQueue.o /home/alex/source/ptokax/obj/hashBanManager.o /home/alex/source/ptokax/obj/hashUsrManager.o /home/alex/source/ptokax/obj/hashRegManager.o /home/alex/source/ptokax/obj/HubCommands.o /home/alex/source/ptokax/obj/IP2Country.o /home/alex/source/ptokax/obj/LanguageManager.o /home/alex/source/ptokax/obj/LuaBanManLib.o /home/alex/source/ptokax/obj/LuaCoreLib.o /home/alex/source/ptokax/obj/LuaIP2CountryLib.o /home/alex/source/ptokax/obj/LuaProfManLib.o /home/alex/source/ptokax/obj/LuaRegManLib.o /home/alex/source/ptokax/obj/LuaScript.o /home/alex/source/ptokax/obj/LuaScriptManager.o /home/alex/source/ptokax/obj/LuaScriptManLib.o /home/alex/source/ptokax/obj/LuaSetManLib.o /home/alex/source/ptokax/obj/LuaTmrManLib.o /home/alex/source/ptokax/obj/LuaUDPDbgLib.o /home/alex/source/ptokax/obj/ProfileManager.o /home/alex/source/ptokax/obj/PtokaX.o /home/alex/source/ptokax/obj/PXBReader.o /home/alex/source/ptokax/obj/pxstring.o /home/alex/source/ptokax/obj/RegThread.o /home/alex/source/ptokax/obj/ResNickManager.o /home/alex/source/ptokax/obj/ServerManager.o /home/alex/source/ptokax/obj/ServerThread.o /home/alex/source/ptokax/obj/serviceLoop.o /home/alex/source/ptokax/obj/SettingManager.o /home/alex/source/ptokax/obj/TextFileManager.o /home/alex/source/ptokax/obj/UdpDebug.o /home/alex/source/ptokax/obj/UDPThread.o /home/alex/source/ptokax/obj/User.o /home/alex/source/ptokax/obj/utility.o /home/alex/source/ptokax/obj/ZlibUtility.o /home/alex/source/ptokax/tinyxml/tinyxml.a /home/alex/source/ptokax/skein/skein.a -o PtokaX -lstdc++ -lpthread -llua5.1 -lrt -lz
/home/alex/source/ptokax/obj/LuaBanManLib.o: In function `RangeTempBan':
/home/alex/source/ptokax/core/LuaBanManLib.cpp:1693: undefined reference to `lua_tonumberx'
/home/alex/source/ptokax/obj/LuaBanManLib.o: In function `TempBanNick':
...


Хотя PtokaX 0.5.0.0 с Lua 5.1 собирается без проблем!

А как можно собрать библиотеку liblua-socket с Lua 5.2?
Go to the top of the page
+Quote Post
Alexey
сообщение 11.1.2014, 17:50
Сообщение #45


7 квадратиков
*******

Группа: Модераторы
Сообщений: 792
Регистрация: 21.1.2009
Пользователь №: 1 895
Спасибо сказали: 300 раз




Цитата(Iskandark @ 9.1.2014, 23:33) *
Хотя PtokaX 0.5.0.0 с Lua 5.1 собирается без проблем!

Видимо, версию 0.5.0.0 ты не пытался предварительно собирать с Lua 5.2, потому она и собирается с Lua 5.1 без проблем. И если ты удалишь промежуточные результаты своих попыток из 0.5.0.1, то она тоже будет собираться с Lua 5.1 без проблем.
Go to the top of the page
+Quote Post
Iskandark
сообщение 13.1.2014, 20:35
Сообщение #46


Активный участник
***

Группа: Пользователи
Сообщений: 61
Регистрация: 24.10.2008
Из: Moscow
Пользователь №: 875
Спасибо сказали: 0 раз




Цитата(Alexey @ 11.1.2014, 18:50) *
Видимо, версию 0.5.0.0 ты не пытался предварительно собирать с Lua 5.2, потому она и собирается с Lua 5.1 без проблем. И если ты удалишь промежуточные результаты своих попыток из 0.5.0.1, то она тоже будет собираться с Lua 5.1 без проблем.


Не понял, как можно собрать 0.5.0.1 с Lua 5.1. Поясни, пожалуйста what.gif
Go to the top of the page
+Quote Post
Saymon21
сообщение 13.1.2014, 22:53
Сообщение #47


Site Reliability Engineer
*********

Группа: Модераторы
Сообщений: 1 772
Регистрация: 27.6.2009
Из: Чувашия, г. Чебоксары
Пользователь №: 3 719
Спасибо сказали: 479 раз




В вики написано же http://wiki.ptokax.org/doku.php?id=guides:debian_bugbuntu
Go to the top of the page
+Quote Post

3 страниц V  < 1 2 3
Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

Collapse

> Похожие темы

  Тема Ответов Автор Просмотров Последнее сообщение
No New Posts Установка Linux хаба DC++ в ANDROID
Теперь ты видел все ))
0 мамин_парень 1 435 5.8.2017, 9:49 Посл. сообщение: мамин_парень
No new Topic has attachmentsPtokaX в OpenWrt (Linux)
Ребята как собрать под эту систему?
21 мамин_парень 13 278 10.4.2017, 15:19 Посл. сообщение: мамин_парень
No new ВАЖНО: Topic has attachmentsМодули для скриптов RusHub
26 Setuper 25 159 21.3.2017, 17:31 Посл. сообщение: Alexey
No New Posts Linux хаб OpenDCHub под Android
Есть кто сможет передлать из программистов форума
7 Sezam 2 572 9.1.2017, 15:42 Посл. сообщение: Saymon21
No New Posts Модули в lua
Модули в lua
2 daslex 3 680 17.11.2013, 19:30 Посл. сообщение: daslex
No New Posts От: Модули Lua В Linux
От темы с ID: 1739
3 Saymon21 3 440 4.11.2013, 18:36 Посл. сообщение: Saymon21
No New Posts linux luaplugin
Проблемы с компиляцией/запуском Луа
8 Тимофей 5 595 27.12.2011, 16:06 Посл. сообщение: Setuper
No new Topic has attachmentsPtokaX 0.4.1.2 - Debian/Ubuntu GNU/Linux
18 Osimus 14 479 16.8.2011, 21:23 Посл. сообщение: DEN 007
No new ВАЖНО: Topic has attachmentsLinux Dc++ Clients
или хождения по граблям
31 mariner 38 606 19.6.2011, 11:36 Посл. сообщение: mariner
No New Posts Ptokax Linux
Помогите .....
12 Ferb 8 973 25.2.2011, 22:55 Посл. сообщение: DEN 007
No New Posts Не удаётся собрать eiskaltdcpp под Linux
0 SUNNY 2 707 8.8.2010, 19:48 Посл. сообщение: SUNNY
Closed PtokaX Linux
5 DarkGod 6 192 10.5.2010, 10:36 Посл. сообщение: Manux
No New Posts От: PtokaX Linux
От темы с ID: 3432
0 Змий 2 376 8.5.2010, 20:41 Посл. сообщение: Змий
No New Posts Topic has attachmentsApexdc++ Для Linux
В разработке
8 Svyat 10 953 6.5.2010, 17:49 Посл. сообщение: Кто-то_из_вне...
No New Posts Где можно скачать Linux sever?
плиз
7 Тёмич 5 004 13.4.2010, 18:18 Посл. сообщение: Nickolya

 



RSS Сейчас: 17.10.2018, 20:19